
Router'ımız HTTP ve FTP server olabildiği gibi TFTP hizmeti de verebilmektedir.
Bunun için server tarafında;
tftp-server flash:cat6500-entservices-mz.122-40.SG.bin
Client tarafında;
copy tftp://1.1.1.1/cat6500-entservices-mz.122-40.SG.bin null:
Özellikle Frame Relay gibi non-broadcast multi access networklerde kullanılır. Bu tip netwoklerde multicast/broadcast olmadığı için "hello" paketleri gönderilemez haliyle komşuluk kurulamaz DR-BDR seçimi yapılamaz. Bu sorunu aşmak için OSPF paketlerini unicast göndermemiz gerekir bunu sağlamak içinde aşağıda görüldüğü gibi OSPF altında neighbor komutu ile HUB da SPOKE'ların adreslerini belirtmemiz gerekir. Yine SPOKE ların birbirleriyle R1 üzerinden haberleşebilmesi nedeniyle DR'ın mutlaka R1 olmasını sağlamak için interface altında "ip ospf priority 0" komutunu yazmamız gerekir.
!R1:
ip address 10.10.1.1 255.255.255.0
!
interface Serial1/0
ip address 10.10.123.1 255.255.255.0
encapsulation frame-relay
frame-relay map ip 10.10.123.2 102
frame-relay map ip 10.10.123.3 103
!
router ospf 1
network 0.0.0.0 255.255.255.255 area 0
neighbor 10.10.123.2
neighbor 10.10.123.3
!
!R2:
!
interface Loopback0
ip address 10.10.2.2 255.255.255.0
!
interface Serial1/0
ip address 10.10.123.2 255.255.255.0
encapsulation frame-relay
ip ospf priority 0
frame-relay map ip 10.10.123.1 201
frame-relay map ip 10.10.123.3 201
!
router ospf 1
network 0.0.0.0 255.255.255.255 area 0
!
!R3:
interface Loopback0
ip address 10.10.3.3 255.255.255.0
!
interface Serial1/0
ip address 10.10.123.3 255.255.255.0
encapsulation frame-relay
ip ospf priority 0
frame-relay map ip 10.10.123.1 301
frame-relay map ip 10.10.123.2 301
!
router ospf 1
network 0.0.0.0 255.255.255.255 area 0
!
Sonuçlar:
*Mar 1 00:25:25.951: OSPF: Send hello to 10.10.123.2 area 0 on Serial1/0 from 10.10.123.1
*Mar 1 00:25:25.955: OSPF: Send hello to 10.10.123.3 area 0 on Serial1/0 from 10.10.123.1
R1#sh ip ospf interface s1/0
Serial1/0 is up, line protocol is up
Internet Address 10.10.123.1/24, Area 0
Process ID 1, Router ID 10.10.1.1, Network Type NON_BROADCAST, Cost: 64
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 10.10.1.1, Interface address 10.10.123.1
No backup designated router on this network
Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
oob-resync timeout 120
Hello due in 00:00:01
Supports Link-local Signaling (LLS)
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 4 msec
Neighbor Count is 2, Adjacent neighbor count is 2
Adjacent with neighbor 10.10.2.2
Adjacent with neighbor 10.10.3.3
Suppress hello for 0 neighbor(s)
R1#sh ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
10.10.2.2 0 FULL/DROTHER 00:01:34 10.10.123.2 Serial1/0
10.10.3.3 0 FULL/DROTHER 00:01:58 10.10.123.3 Serial1/0
*Mar 1 00:31:15.139: OSPF: Send hello to 224.0.0.5 area 0 on Serial1/0.12 from 10.1.12.1
R1#sh ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
10.10.2.2 0 FULL/ - 00:00:33 10.1.12.2 Serial1/0.12
R1#sh ip ospf interface s1/0.12
Serial1/0.12 is up, line protocol is up
Internet Address 10.1.12.1/24, Area 0
Process ID 1, Router ID 10.10.1.1, Network Type POINT_TO_POINT, Cost: 64
Transmit Delay is 1 sec, State POINT_TO_POINT,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:02
Supports Link-local Signaling (LLS)
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 10.10.2.2
Suppress hello for 0 neighbor(s)
R1#sh run
interface Serial1/0
no ip address
encapsulation frame-relay
!
interface Serial1/0.12 point-to-point
ip address 10.1.12.1 255.255.255.0
frame-relay interface-dlci 102
!
Cisco cihazlarda konfigirasyon yedegi almak cok onemli ve mutlaka yapılması gereken bir iştir. Problem oluştuğunda önceki konfigirasyonlara dönebilmek sistemin arıza süresini kısaltarak EoC'i (end of career) önler:)
Bu işlemi yapmadan önce yedeği nereye nasil ve ne zaman alacağımıza karar vermemiz gerekir. Benim tavsiyem yedeklerin değişiklik yapıldığında ve güvenli bir ftp sunucuya alınmasıdır.
FTP sunucu ayarladıktan sonra kullanıcımızı oluşturalım:
ip ftp username mcap
ip ftp password secret
Bu islemden sonra yer ve zaman bilgilerini girelim:
archive
write-memory
Yukarida cihazımızda yaptığımız değişiklikleri kaydetmek icin komut verdiğimizde konfigirasyon dosyasi tanımladığımız FTP sunucuya gönderilecektir.
R1#show archive
The next archive file will be named ftp://10.1.1.1/R1-config-2
Archive # Name
0
1 ftp://10.1.1.1/R1-config-1 <- Most Recent
2
3
4
5
6
7
8
9
10
11
12
13
14
Peki acaba FTP'ye kaydettigimiz konfigirasyon dosyasiyla şu anda çalışan sistem dosyasi arasinda fark varmıdır? Bunu anlamak için hemen bir loopback interface oluşturup IP verelim ve nasıl karşılaştıracağımıza bakalım:
R1#show archive config differences ftp://10.1.1.1/R1-config-1 system:running-config
Contextual Config Diffs:
+interface Loopback99
+ip address 1.1.1.1 255.255.255.255
FTP'deki sistem dosyasini çalışan konfig dosyasiyla değiştirmek için yani yedekten geri dönmek için:
R1#configure replace ftp://10.1.1.1/R1-config-1 list force
Loading R1-config-1 !!
[OK - 7400/4096 bytes]
!Pass 1
!List of Commands:
no interface Loopback99
end
Total number of passes: 1
Rollback Done
Switch(config)# interface fastethernet0/1
Switch(config-if)# storm-control unicast level bps 1m
Switch(config)# interface fastethernet0/1
Switch(config-if)# srr-queue bandwidth limit 50
Bu LAB'daki amacimiz Subedeki VOIP networkunun G.SHDSL devre uzerinden EIGRP ile, LAN networkunun LisedLine devre uzerinden OSPF ile birbirlerini yedekleyerek merkezle haberlesmesi.
Normal olarak bu yapida EIGRP nin Administrative Distance degeri (90), OSPF ten (110) kucuk oldugundan tum trafik EIGRP ile G.SHDSL devre uzerinden tasinmaktadir.
R2#sh ip route
O 10.1.13.0 [110/65] via 10.1.124.1, 00:51:48, FastEthernet0/0
C 10.1.23.0 is directly connected, Serial1/0
D 10.1.38.0 [90/2172416] via 10.1.23.3, 00:00:14, Serial1/0
D 10.1.37.0 [90/2172416] via 10.1.23.3, 00:00:14, Serial1/0
C 10.1.124.0 is directly connected, FastEthernet0/0
R1#sh ip route
C 10.1.13.0 is directly connected, Serial1/1
D 10.1.23.0 [90/2172416] via 10.1.124.2, 00:03:18, FastEthernet0/0
D 10.1.38.0 [90/2174976] via 10.1.124.2, 00:03:00, FastEthernet0/0
D 10.1.37.0 [90/2174976] via 10.1.124.2, 00:03:00, FastEthernet0/0
C 10.1.124.0 is directly connected, FastEthernet0/0
Ama bizim istedigimiz VOIP'in G.SHDSL ile LAN'in LisedLine ile tasinmasidir.
Tum networkler EIGRP ile R2 uzerinden merkeze tasindigina gore R2 uzerinde birseyler yapmamiz lazim. LAN networkunun LL devre uzerinden akmasi icin R2 deki EIGRP uzerinde LAN'a ait AD degerini OSPF AD degeri uzerinde cikarirsak zaten OSPF database'inde olan LAN networkunu R2'nin routing tablosuna sokabiliriz.
Once LAN networkunu bir ACL ile belirleyelim:
R2(config)#ip access-list standard LAN
R2(config-std-nacl)#permit 10.1.37.0 0.0.0.255
Simdide LAN networkunun EIGRP de distance degerini OSPF'in uzerine cikaralim:
R2(config)#router ei 1
R2(config-router)#distance 150 10.1.23.3 0.0.0.0 LAN
R2(config-router)#end
*Mar 1 01:21:17.567: %SYS-5-CONFIG_I: Configured from console by console
*Mar 1 01:21:17.647: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 10.1.23.3 (Serial1/0) is down: route configuration changed
*Mar 1 01:21:17.671: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 10.1.124.1 (FastEthernet0/0) is down: route configuration changed
R2#
*Mar 1 01:21:20.755: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 10.1.124.1 (FastEthernet0/0) is up: new adjacency
R2#
*Mar 1 01:21:59.343: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 10.1.23.3 (Serial1/0) is up: new adjacency
Routing tablosunu tekrar kontrol edelim:
R2#sh ip route
O 10.1.13.0 [110/65] via 10.1.124.1, 01:22:17, FastEthernet0/0
C 10.1.23.0 is directly connected, Serial1/0
D 10.1.38.0 [90/2172416] via 10.1.23.3, 00:01:53, Serial1/0
O 10.1.37.0 [110/66] via 10.1.124.1, 00:02:37, FastEthernet0/0
C 10.1.124.0 is directly connected, FastEthernet0/0
R1#sh ip route
C 10.1.13.0 is directly connected, Serial1/1
D 10.1.23.0 [90/2172416] via 10.1.124.2, 00:13:46, FastEthernet0/0
D 10.1.38.0 [90/2174976] via 10.1.124.2, 00:13:08, FastEthernet0/0
O 10.1.37.0 [110/65] via 10.1.13.3, 00:13:52, Serial1/1
C 10.1.124.0 is directly connected, FastEthernet0/0
Distance komutundaki 150 AD degeridir. 150 yapmamin nedeni OSPF'in AD degerinden (110) buyuk bir deger olmasidir yani 111 de olabilir.
Distance komutundaki diger bir parametre de "IP Source Address" EIGRP update'i aldigim komsumun adresidir.
Distance komutunda son olarak ta standart ACL ismini belirtiyoruz.
Son olarak R2 EIGRP tablosundaki route'larin merkezdeki OSPF'e duyrulmasi gerekir. Yedeklilik polikitamiz geregi LL devrenin kopmasi durumunda OSPF'in EIGRP route larini G.SHDSL devre uzerinden almasi gerekir.
R2(config)#router ospf 1
R2(config-router)#redistribute eigrp 1 subnets
R2(config-router)#end
R2#clear ip ospf process
Reset ALL OSPF processes? [no]: y
*Mar 1 01:43:09.251: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.124.1 on FastEthernet0/0 from FULL to DOWN, Neighbor Down: Interface down or detached
*Mar 1 01:43:09.251: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.124.4 on FastEthernet0/0 from FULL to DOWN, Neighbor Down: Interface down or detached
*Mar 1 01:43:09.383: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.124.1 on FastEthernet0/0 from LOADING to FULL, Loading Done
*Mar 1 01:43:09.383: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.124.4 on FastEthernet0/0 from LOADING to FULL, Loading Done
R4#sh ip route
O 10.1.13.0 [110/65] via 10.1.124.1, 00:00:21, FastEthernet0/0
O E2 10.1.23.0 [110/20] via 10.1.124.2, 00:00:21, FastEthernet0/0
O 10.1.38.0 [110/66] via 10.1.124.1, 00:00:21, FastEthernet0/0
O 10.1.37.0 [110/66] via 10.1.124.1, 00:00:21, FastEthernet0/0
C 10.1.124.0 is directly connected, FastEthernet0/0
LL devreyi kapatirsak:
R1(config)#int s1/1
R1(config-if)#shutdown
*Mar 1 01:52:53.299: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.38.3 on Serial1/1 from FULL to DOWN, Neighbor Down: Interface down or detached
R1(config-if)#
*Mar 1 01:52:55.295: %LINK-5-CHANGED: Interface Serial1/1, changed state to administratively down
*Mar 1 01:52:56.295: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/1, changed state to down
R4#sh ip route
O E2 10.1.23.0 [110/20] via 10.1.124.2, 00:01:20, FastEthernet0/0
O E2 10.1.38.0 [110/20] via 10.1.124.2, 00:01:20, FastEthernet0/0
O E2 10.1.37.0 [110/20] via 10.1.124.2, 00:01:20, FastEthernet0/0
C 10.1.124.0 is directly connected, FastEthernet0/0
G.SHDSL devreyi kapatalim:
R2(config)#int s1/0
R2(config-if)#shutdown
R2(config-if)#
*Mar 1 01:56:58.659: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 10.1.23.3 (Serial1/0) is down: interface down
R2(config-if)#
*Mar 1 01:57:00.523: %LINK-5-CHANGED: Interface Serial1/0, changed state to administratively down
*Mar 1 01:57:01.523: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed state to down
R4#sh ip route
O 10.1.13.0 [110/65] via 10.1.124.1, 00:01:36, FastEthernet0/0
O 10.1.38.0 [110/66] via 10.1.124.1, 00:01:36, FastEthernet0/0
O 10.1.37.0 [110/66] via 10.1.124.1, 00:01:36, FastEthernet0/0
C 10.1.124.0 is directly connected, FastEthernet0/0